Mailing lists are not working
Incident Report for Eclipse Foundation Services
Resolved
This incident has been resolved.
Posted Oct 18, 2021 - 09:28 EDT
Investigating
We are currently investigating this issue.
Posted Oct 18, 2021 - 06:41 EDT
This incident affected: Others (Mailing lists).