Gerrit is under heavy load
Incident Report for Eclipse Foundation Services
Postmortem

We were again hit by a DoS attack resulting in a very high load of the service. Thus, the service was having a hard time to process the legitimate requests in a timely fashion.

The service is reverse-proxied. The front proxy returns a HTTP 502 to clients when the backend service does not reply fast enough: that is the error that users were seeing during the attack.

We blocked the IP subnet responsible for the attack. Immediately, the workload started to drop. It reached back its usual level in a couple of minutes: the service was back, fully operational.

Posted Dec 03, 2020 - 02:56 EST

Resolved
This incident has been resolved.
Posted Dec 03, 2020 - 02:46 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2020 - 02:28 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 03, 2020 - 02:25 EST
Investigating
We are currently investigating. You may experience some 502 bad gateway meanwhile.
Posted Dec 03, 2020 - 02:16 EST
This incident affected: Core Services (git.eclipse.org/r).